use strict;
my $str = 'C:/Users/10MedicineA\\20072018_medicineName_00222_01111
C:/Users/MedicineB\\21072018_medicineName_03333_01121
Users/3A Medicine\\\\200726_21-PQmed_00223_07_01110';
my $regex = qr/(\d+)_([^_]*)_(\d+)_/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}