$re = '/(\d+)_([^_]*)_(\d+)_/m';
$str = 'C:/Users/10MedicineA\\20072018_medicineName_00222_01111
C:/Users/MedicineB\\21072018_medicineName_03333_01121
Users/3A Medicine\\\\200726_21-PQmed_00223_07_01110';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);