// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)_([^_]*)_(\d+)_").unwrap();
let string = "C:/Users/10MedicineA\\20072018_medicineName_00222_01111
C:/Users/MedicineB\\21072018_medicineName_03333_01121
Users/3A Medicine\\\\200726_21-PQmed_00223_07_01110";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}