#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[2-9]\d|[1-9]\d\d|[1-9],\d{3})(?:,\d{3})+$"
Local $sString = "123,456,789,012,345" & @CRLF & _
"12,345" & @CRLF & _
"19,000" & @CRLF & _
"20,000" & @CRLF & _
"21,000" & @CRLF & _
"023,555" & @CRLF & _
"21,939,323" & @CRLF & _
"1,232,323" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")