$re = '/[A-Z]{4}\-[A-Z]{4}\-[A-Z]{4}/m';
$str = 'specific text string here AAAA-BBBB-XXXX variable text string after';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);