$re = '/(?<=rbl-value:)\w+\b/m';
$str = 'asd123 ghjkasd rbl-value:inputName hjlqwezuo rbl-value:something asd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);