import re
regex = re.compile(r"(\d+\.([1-9]{3}|[1-9]{2}|[1-9]|0{1}))(\d*)", flags=re.MULTILINE)
test_str = ("#提取有效小数的思路:匹配出符合要求的组合不符合要求的组。\n"
"#使用sub函数,re.sub(pat,lambda m:m[1],s)\n"
"#repl使用函数,传递的参数是pat,所匹配的match对象,提取match对象中符合要求的组即可。\n"
"124.1230000012\n"
"124.1200003412\n"
"123.0000000012\n"
"1.2000\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")