re = /(?m)^\*{4}[\r\n]([\s\S]+?(?=^\*{4}[\r\n]))^\*{4}[\r\n]/m
str = 'dfdsfsdf
****
afd
****
****
*****
nested
*****
fdfds
****
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end