const regex = /(<\?php echo L10n\:\:icon\(')(.*?)('\); \?>)(\n)(\s+)(<\?php echo UI\:\:timeago)(.*?)(\); \?\>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\?php echo L10n\\:\\:icon\\(\')(.*?)(\'\\); \\?>)(\\n)(\\s+)(<\\?php echo UI\\:\\:timeago)(.*?)(\\); \\?\\>)', 'gm')
const str = `<?php echo L10n::icon('calendar'); ?>
<?php echo UI::timeago(\$License->iso_8601_purchased, \$License->purchased); ?>`;
const subst = `$6$7, '$2'$8`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);