use strict;
my $str = '1EXE_IN1EXE_CO2CONTENT_ACCESS3CONTENT_ACCESS
3CONTENT_ACCESS1EXE_IN
1EXE_IN2CONTENT_ACCESS3CONTENT_ACCESS';
my $regex = qr/(?:\G(?!^)(?(?=\d+(?:EXE_CO|EXE_IN))(?<!\dCONTENT_ACCESS))|(?=(?:\d+(?:EXE_CO|EXE_IN))+(?:\d+CONTENT_ACCESS)+))(\d+)(EXE_CO|EXE_IN|CONTENT_ACCESS)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}