import Foundation
let pattern = #"(?:\G(?!^)(?(?=\d+(?:EXE_CO|EXE_IN))(?<!\dCONTENT_ACCESS))|(?=(?:\d+(?:EXE_CO|EXE_IN))+(?:\d+CONTENT_ACCESS)+))(\d+)(EXE_CO|EXE_IN|CONTENT_ACCESS)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1EXE_IN1EXE_CO2CONTENT_ACCESS3CONTENT_ACCESS
3CONTENT_ACCESS1EXE_IN
1EXE_IN2CONTENT_ACCESS3CONTENT_ACCESS
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)