const regex = /^[^\[]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\[]+', 'gm')
const str = `Order[NN(STTS)]
523:10[CARD(STTS)]
Euro12[NN(STTS)]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);