import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w*)=(\\\".*?\\\"|\\S*)";
final String string = "Message meets Alert condition\n\n"
+ "date=2020-08-20 time=00:33:57 devname=FGT3HD3999906624 devid=FGT3HD3999906624 logid=\"0100032003\" type=\"event\" subtype=\"system\" level=\"information\" vd=\"root\" eventtime=1597847637407862934 tz=\"+1000\" logdesc=\"Admin logout successful\" sn=\"159999794\" user=\"admin\" ui=\"https(10.198.199.105)\" method=\"https\" srcip=10.198.199.105 dstip=192.168.23.254 action=\"logout\" status=\"success\" duration=4843 reason=\"timeout\" msg=\"Administrator admin timed out on https(10.198.199.105)\"\n\n"
+ "Administrator IT Administrator Ph:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}