using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[A-Za-z][A-Za-z0-9\.\-\_]+$)|(^[\w\-\.\+]+@([\w-]+\.)+[\w-]{2,4}$)";
string input = @"User1.2.3
simpleuser123
simpleuser_123
simpleuser-123
1baduser
.baduser
_baduser
1bob-is.great_999+456@gmail.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}