const regex = /(^[A-Za-z][A-Za-z0-9\.\-\_]+$)|(^[\w\-\.\+]+@([\w-]+\.)+[\w-]{2,4}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[A-Za-z][A-Za-z0-9\\.\\-\\_]+$)|(^[\\w\\-\\.\\+]+@([\\w-]+\\.)+[\\w-]{2,4}$)', 'gm')
const str = `User1.2.3
simpleuser123
simpleuser_123
simpleuser-123
1baduser
.baduser
_baduser
1bob-is.great_999+456@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}