re = /(^[A-Za-z][A-Za-z0-9\.\-\_]+$)|(^[\w\-\.\+]+@([\w-]+\.)+[\w-]{2,4}$)/m
str = 'User1.2.3
simpleuser123
simpleuser_123
simpleuser-123
1baduser
.baduser
_baduser
1bob-is.great_999+456@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end