$re = '/(?<x_hello_abc>\d+\.\d+\.\d+\.\d+)/m';
$str = '"x-hello-abc":["101.2.10.1, 102.3.4.3, 12.3.45.5"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);