# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(la)(la[l]?)*(f.*)/$3/g;t' <<< "lalalalalalaffffff"