using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(la)(la[l]?)*(f.*)";
string substitution = @"$3";
string input = @"lalalalalalaffffff";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}