package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(la)(la[l]?)*(f.*)`)
var str = `lalalalalalaffffff`
var substitution = "$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}