use strict;
my $str = 'lalalalalalaffffff';
my $regex = qr/(la)(la[l]?)*(f.*)/p;
my $subst = '$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";