using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^CH([0-3][\d]{0,5})$";
string input = @"CH300000";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}