// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S+\W*?\S{3,}").unwrap();
let string = "«Тостер» — это узкоспециализированный сервис вопросов и ответов, предназначенный для IT-специалистов и всех тех, кто отчаянно пытается ими стать. Название сервиса восходит к одноименным IT-мероприятиям и призвано символизировать преемственность традиции обмена опытом между IT-специалистами.
Миссия «Тостера» — создание открытой платформы для обмена полезной информацией и формирование на ее основе общедоступной структурированной базы знаний в области информационных технологий и смежных с ней областей (например, информационного права и компьютерной лингвистики).";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}