$re = '/^(?!.*(?=AA.*XX.*ZZ).*).*AA.*ZZ.*$/m';
$str = 'IYAABMDHRPONWUYZZ
BVAABDMYBXXWZZCKU
AABMDHRPONWUYXxXxXxZZ
BVAABDZZMYBXXWCKU
anythingelse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);