$re = '/^\s*product \{\n\s*.*(?<!id)$/m';
$str = ' product {
id';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);