use strict;
my $str = 'foo/bar
FanFicFare rules!';
my $regex = qr/(.*)/mp;
my $subst = '[Characters].\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";