#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w*\/[^\/]*\/(?<my_field>\S*)\s*$"
Local $sString = "" & @CRLF & _
"datastore1/packer-centos6/packer-centos6 " & @CRLF & _
"datastore1/packer-win12/packer-win12 " & @CRLF & _
"datastore1/packer_centos6/packer_centos6 " & @CRLF & _
"datastore1/packer_centos7/packer_centos7 " & @CRLF & _
"datastore1/packer_ubuntu18/packer_ubuntu18 " & @CRLF & _
"datastore1/packer_ubuntu20/packer_ubuntu20"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")