using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w*\/[^\/]*\/(?<my_field>\S*)\s*$";
string input = @"
datastore1/packer-centos6/packer-centos6
datastore1/packer-win12/packer-win12
datastore1/packer_centos6/packer_centos6
datastore1/packer_centos7/packer_centos7
datastore1/packer_ubuntu18/packer_ubuntu18
datastore1/packer_ubuntu20/packer_ubuntu20";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}