import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w*\\/[^\\/]*\\/(?<my_field>\\S*)\\s*$";
final String string = "\n"
+ "datastore1/packer-centos6/packer-centos6 \n"
+ "datastore1/packer-win12/packer-win12 \n"
+ "datastore1/packer_centos6/packer_centos6 \n"
+ "datastore1/packer_centos7/packer_centos7 \n"
+ "datastore1/packer_ubuntu18/packer_ubuntu18 \n"
+ "datastore1/packer_ubuntu20/packer_ubuntu20";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}