#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s) *({{< ?file(?:-excerpt)? [^>]* ?>}}.*?{{< ?/ ?file(?:-excerpt)? ?>}})"
Local $sString = " {{< file "hello.go" go >}}" & @CRLF & _
"package main" & @CRLF & _
"" & @CRLF & _
"import "fmt"" & @CRLF & _
"" & @CRLF & _
"func main() {" & @CRLF & _
" fmt.Printf("hello, world\n")" & @CRLF & _
"}" & @CRLF & _
"{{</ file >}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")