#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)®(?=[^<>]*(?:<[^>]*>[^<]*)*$)"
Local $sString = "<img title="Copyright replacement incorrect ®" src="/fileadmin/filexyz.png">" & @CRLF & _
"<h1>Copyright replacement correct: ®</h1>" & @CRLF & _
"Also correct replacement here: ®" & @CRLF & _
""
Local $sSubst = "<sup>®</sup>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)