const regex = /®(?=[^<>]*(?:<[^>]*>[^<]*)*$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('®(?=[^<>]*(?:<[^>]*>[^<]*)*$)', 'gim')
const str = `<img title="Copyright replacement incorrect ®" src="/fileadmin/filexyz.png">
<h1>Copyright replacement correct: ®</h1>
Also correct replacement here: ®
`;
const subst = `<sup>®</sup>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);