use strict;
my $str = '<img title="Copyright replacement incorrect ®" src="/fileadmin/filexyz.png">
<h1>Copyright replacement correct: ®</h1>
Also correct replacement here: ®
';
my $regex = qr/®(?=[^<>]*(?:<[^>]*>[^<]*)*$)/imp;
my $subst = '<sup>®</sup>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";