# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<YEAR>[\d]{4})-(?P<MONTH>([0][1-9])|([1][0-2]))-(?P<DAY>([0][1-9])|([12][0-9])|([3][01]))T(?P<HOUR>([01][0-9])|([2][0-3])):(?P<MINUTES>([0-5][0-9])):(?P<SECONDS>([0-5][0-9])).(?P<MILLIS>[0-9]{3})Z"
test_str = ("<Id>2016-06-29T17:03:37.000Z</Id>\n"
"<Lap StartTime=\"2016-06-29T17:03:37.000Z\">\n"
"<TotalTimeSeconds>6906</TotalTimeSeconds>\n"
"<DistanceMeters>60870.5</DistanceMeters>\n"
"<Intensity>Active</Intensity>\n"
"<TriggerMethod>Manual</TriggerMethod>\n"
"<Track>\n"
"<Trackpoint>\n"
"<Time>2016-06-29T17:03:37.000Z</Time>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.