$re = '/\(((?>\\\\.|[^()])+)\)/m';
$str = 'a(bb)(cc)dd\\(ee\\)(ff)(gg\\(hh\\)ii)jj()kk(\\(\\))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);