#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\D*(?:26|555))(?=(?:\D*\d){5}\D*$)[\d()-]{5,10}$"
Local $sString = "Valid inputs:" & @CRLF & _
"(12345)--" & @CRLF & _
"---12)567)" & @CRLF & _
"12333" & @CRLF & _
"-1-2--3-45" & @CRLF & _
"(()))12345" & @CRLF & _
"((12345" & @CRLF & _
"(-)65768-" & @CRLF & _
"(4)1-2-35" & @CRLF & _
"" & @CRLF & _
"Invalid inputs:" & @CRLF & _
"26123---" & @CRLF & _
"(26)897---" & @CRLF & _
"-26333----" & @CRLF & _
"26" & @CRLF & _
"26(((())" & @CRLF & _
"26------" & @CRLF & _
"26--345" & @CRLF & _
"26)88-76" & @CRLF & _
"267-9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")