# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!\D*(?:26|555))(?=(?:\D*\d){5}\D*$)[\d()-]{5,10}$"
test_str = ("Valid inputs:\n"
"(12345)--\n"
"---12)567)\n"
"12333\n"
"-1-2--3-45\n"
"(()))12345\n"
"((12345\n"
"(-)65768-\n"
"(4)1-2-35\n\n"
"Invalid inputs:\n"
"26123---\n"
"(26)897---\n"
"-26333----\n"
"26\n"
"26(((())\n"
"26------\n"
"26--345\n"
"26)88-76\n"
"267-9")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.