$re = '/(?<=\.Value\[)(?:{*)([^}]+)(?=[\]}])/';
$str = '{{server/Y2KCluster1:[]ServerServerStatusState}}.Value[{{{server/Y2KCluster2:[]ServerServerStatusSecondsTillShutdown}}}]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);