?repeats the group contents below at most once:
^start of line
httpthe literal text http (case sensitive) httpsthe literal text https (case sensitive) :the literal : (5810 / 728 / 3A16)
\/the literal / (4710 / 578 / 2F16)
\/the literal / (4710 / 578 / 2F16)