using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"HTTP_TOKEN=(.+)&";
string input = @"https://website.com/?HTTP_TARGETPORTAL=7&HTTP_TOKEN=somedata&HSID_DOMAIN_URL=...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}