re = /HTTP_TOKEN=(.+)&/m
str = 'https://website.com/?HTTP_TARGETPORTAL=7&HTTP_TOKEN=somedata&HSID_DOMAIN_URL=...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end