$re = '/0([0-9]{2})/m';
$str = '05-09-014
05-08-01
016-06-06';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;