package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^mongodb:\/\/[^\/\,]+:{1}[^\/\,]*@{1}.*$`)
var str = `mongodb://username:pas5w0rd@db1.example.net,app:user@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000
mongodb://db1.example.net, username:pas5w0rd@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}