re = /.*?\B@\w{5}.*/m
str = 'Pattern should match all this lines :
Hi @username how are you?
Hi @username.how are you?
😉@username.
And should not match email like this:
Hi email to something@domain.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end