// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*?\B@\w{5}.*").unwrap();
let string = "Pattern should match all this lines :
Hi @username how are you?
Hi @username.how are you?
😉@username.
And should not match email like this:
Hi email to something@domain.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}