const regex = /\(|,|\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(|,|\\)', 'g')
const str = `(\$10,890.09)`;
const subst = `$10890.09`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);