package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\$*)(\s*)some latex(\s*)(?:\$*)`)
var str = `$some latex$
$$
some latex
$$
`
var substitution = "{% math %}\1some latex\2{% endmath %}"
fmt.Println(re.ReplaceAllString(str, substitution))
}