# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"the"
test_str = ("Here are some words: one, two, three, FOUR. \n"
"And here are some numbers: 1, 2, 3, 4, 10, 20, 30, 40, 100, 200, 300, 400, 1000. \n"
"Here are some mixed things: A1, A2, A3, A4\n"
"3 + 4 = 7\n"
"12 / 3 = 4\n"
"2 ^ 2 = 4\n\n"
"I think I've seen this film before\n"
"And I didn't like the ending\n"
"You're not my homeland anymore\n"
"So what am I defending now?\n"
"You were my town\n"
"Now I'm in exile, seein' you out\n"
"I think I've seen this film before\n\n"
" I can see you starin', honey\n"
"Like he's just your understudy\n"
"Like you'd get your knuckles bloody for me\n"
"Second, third, and hundredth chances\n"
"Balancin' on breaking branches\n"
"Those eyes add insult to injury")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.