// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(sz=\d+)").unwrap();
let string = "www.somelink/phoyto.jpg/?sz=50
www.somelink/phoyto.jpg/?sz=500
www.somelink/phoyto.jpg/?sz=5
www.somelink/phoyto.jpg/?sz=666";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}