use strict;
my $str = 'I want to delete anything in a line but stop before the word NOA if that is present in a line. NOA will also follow a colon.
1: NOA Keep this)
2 lkajsflk: DONT KEEP THIS
asdlkjfaskldjf: Dont keep this
asdfjlka: NOA
asdf:NOA(lkjasdlfkjasf)
Version: RE2 for Google Sheets
';
my $regex = qr`^(?:[^N\n]|N(?:[^O\n]|O(?:[^A\n]|$)|$)|$)+`mp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";